Google Analytics plugin upgrade error brings down entire wordpress website

Google Analytics plugin upgrade error brings down entire wordpress website

Perhaps you just upgraded your Google Analytics plugin on WordPress, and then anytime anyone tries to load your site, they’re greeted with one of the following errors:
Fatal error: Can’t use function return value in write context in /home2/gkmoney/public_html/wp-content/plugins/googleanalytics/class/Ga_Admin.php on line 106
or
Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in wp-content/plugins/googleanalytics/class/Ga_Admin.php on line 480
What’s great is that you can no longer even get to your WordPress Admin page to disable the plugin. Meanwhile, your site is completely down.

Solution:

Use FTP or your hosting control panel and delete the directory:

<wordpress root>/wp-content/plugins/googleanalytics/

After that, WordPress should load normally for the published and admin pages

 

Followup:

Report your errors/look for other solutions here:
https://wordpress.org/support/plugin/googleanalytics

Here’s another thread with help on the problem:
https://wordpress.org/support/topic/causing-fatal-error-after-updating/

Leave a Reply

Your email address will not be published. Required fields are marked *